原创经验:解决树莓派apt升级/安装提示依赖问题

Posted Posted in 入门, 新玩意, 树莓派, 菜鸟

树莓派上通过apt安装各种应用的时候始终有如下依赖错误提示:

有一些软件包无法被安装。如果您使用的是unstable发行版,这也许是因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件包尚未被创建或者是它们已被从新到(Incoming)目录移出。下列软件包未满足依赖关系。

【原创】本文已经上传至百度经验:https://jingyan.baidu.com/article/6b1823090fa81bfa59e1594e.html

这是个常见的“安装源与本地系统分支不符”导致的问题,而本次问题的主要原因是:

使用PINN在树莓派上安装的多系统启动,因为官方的迷之原因,在安装完树莓派官方Debian系统之后source源指向的是旧版本,并未跟随新版更新。

….[阅读全文]